Known Exploited Vulnerability
7.8
HIGH
CVE-2021-3560
Red Hat Polkit Incorrect Authorization Vulnerabili - [Actively Exploited]
Description

It was found that polkit could be tricked into bypassing the credential checks for D-Bus requests, elevating the privileges of the requestor to the root user. This flaw could be used by an unprivileged local attacker to, for example, create a new local administrator. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

INFO

Published Date :

Feb. 16, 2022, 7:15 p.m.

Last Modified :

June 27, 2024, 7:23 p.m.

Remotely Exploitable :

No

Impact Score :

5.9

Exploitability Score :

1.8
CISA Notification
CISA KEV (Known Exploited Vulnerabilities)

For the benefit of the cybersecurity community and network defenders—and to help every organization better manage vulnerabilities and keep pace with threat activity—CISA maintains the authoritative source of vulnerabilities that have been exploited in the wild.

Description :

Red Hat Polkit contains an incorrect authorization vulnerability through the bypassing of credential checks for D-Bus requests, allowing for privilege escalation.

Required Action :

Apply updates per vendor instructions.

Notes :

https://bugzilla.redhat.com/show_bug.cgi?id=1961710

Public PoC/Exploit Available at Github

CVE-2021-3560 has a 102 public PoC/Exploit available at Github. Go to the Public Exploits tab to see the list.

Affected Products

The following products are affected by CVE-2021-3560 vulnerability. Even if cvefeed.io is aware of the exact versions of the products that are affected, the information is not represented in the table below.

ID Vendor Product Action
1 Redhat enterprise_linux
2 Redhat openshift_container_platform
3 Redhat virtualization
4 Redhat virtualization_host
1 Canonical ubuntu_linux
1 Debian debian_linux
1 Polkit_project polkit
References to Advisories, Solutions, and Tools

Here, you will find a curated list of external links that provide in-depth information, practical solutions, and valuable tools related to CVE-2021-3560.

URL Resource
http://packetstormsecurity.com/files/172836/polkit-Authentication-Bypass.html Third Party Advisory VDB Entry
http://packetstormsecurity.com/files/172846/Facebook-Fizz-Denial-Of-Service.html Third Party Advisory VDB Entry
https://bugzilla.redhat.com/show_bug.cgi?id=1961710 Issue Tracking Patch Vendor Advisory
https://github.blog/2021-06-10-privilege-escalation-polkit-root-on-linux-with-bug/ Exploit Third Party Advisory

We scan GitHub repositories to detect new proof-of-concept exploits. Following list is a collection of public exploits and proof-of-concepts, which have been published on GitHub (sorted by the most recently updated).

None

Updated: 1 week, 1 day ago
0 stars 0 fork 0 watcher
Born at : July 13, 2024, 1:58 p.m. This repo has been linked 9 different CVEs too.

a list of 350+ Free TryHackMe rooms to start learning cybersecurity with THM

ctf cyber cybersecurity roadmap tools tryhackme

Updated: 1 week, 4 days ago
0 stars 0 fork 0 watcher
Born at : July 10, 2024, 1:15 p.m. This repo has been linked 5 different CVEs too.

None

Updated: 4 weeks ago
0 stars 0 fork 0 watcher
Born at : June 23, 2024, 7:42 a.m. This repo has been linked 9 different CVEs too.

Roadmap for Tryhackme

Updated: 1 month ago
0 stars 0 fork 0 watcher
Born at : June 17, 2024, 1:18 p.m. This repo has been linked 5 different CVEs too.

None

Updated: 1 month, 1 week ago
0 stars 0 fork 0 watcher
Born at : June 9, 2024, 1:19 p.m. This repo has been linked 5 different CVEs too.

linpeas.sh

Shell

Updated: 4 weeks ago
2 stars 0 fork 0 watcher
Born at : June 7, 2024, 4:52 p.m. This repo has been linked 8 different CVEs too.

None

Python Shell

Updated: 2 days, 19 hours ago
8 stars 1 fork 1 watcher
Born at : May 29, 2024, 7:50 a.m. This repo has been linked 7 different CVEs too.

None

Shell

Updated: 3 months, 3 weeks ago
0 stars 0 fork 0 watcher
Born at : March 29, 2024, 6:57 a.m. This repo has been linked 1 different CVEs too.

None

Python C Shell

Updated: 1 week, 1 day ago
1 stars 0 fork 0 watcher
Born at : March 29, 2024, 5:29 a.m. This repo has been linked 62 different CVEs too.

Part of my cybersecurity thesis consists in exploring and exploiting this vulnerability.

Python

Updated: 1 month ago
2 stars 0 fork 0 watcher
Born at : March 24, 2024, 11:37 a.m. This repo has been linked 1 different CVEs too.

All CVE - PoC in GitHub

poc proofofconcept tester allcve cvegithub cvenew cvepoc cveupdate

Updated: 3 months, 3 weeks ago
2 stars 2 fork 2 watcher
Born at : March 22, 2024, 3:58 p.m. This repo has been linked 928 different CVEs too.

None

Makefile Go

Updated: 3 months, 4 weeks ago
0 stars 0 fork 0 watcher
Born at : March 22, 2024, 10:49 a.m. This repo has been linked 3 different CVEs too.

None

Updated: 4 months, 1 week ago
1 stars 0 fork 0 watcher
Born at : March 11, 2024, 1:21 p.m. This repo has been linked 930 different CVEs too.

OffSec Certified Professional Certification (OSCP).

oscp oscp-cheatsheet oscp-guide oscp-journey oscp-prep oscp-tools offsec-certified-professional-certification offensive-security offensivesecurity awesome-list awesome-lists cheatsheet offensive-ops

Updated: 4 months, 2 weeks ago
1 stars 0 fork 0 watcher
Born at : March 5, 2024, 9:21 a.m. This repo has been linked 61 different CVEs too.

汽车内核提取漏洞

Updated: 4 months, 3 weeks ago
1 stars 1 fork 1 watcher
Born at : Feb. 29, 2024, 8:49 a.m. This repo has been linked 4 different CVEs too.

Results are limited to the first 15 repositories due to potential performance issues.

The following table lists the changes that have been made to the CVE-2021-3560 vulnerability over time.

Vulnerability history details can be useful for understanding the evolution of a vulnerability, and for identifying the most recent changes that may impact the vulnerability's severity, exploitability, or other characteristics.

  • Modified Analysis by [email protected]

    Jun. 27, 2024

    Action Type Old Value New Value
    Changed Reference Type http://packetstormsecurity.com/files/172836/polkit-Authentication-Bypass.html No Types Assigned http://packetstormsecurity.com/files/172836/polkit-Authentication-Bypass.html Third Party Advisory, VDB Entry
    Changed Reference Type http://packetstormsecurity.com/files/172846/Facebook-Fizz-Denial-Of-Service.html No Types Assigned http://packetstormsecurity.com/files/172846/Facebook-Fizz-Denial-Of-Service.html Third Party Advisory, VDB Entry
  • CVE Modified by [email protected]

    May. 14, 2024

    Action Type Old Value New Value
  • CVE Modified by [email protected]

    Nov. 07, 2023

    Action Type Old Value New Value
    Added Reference Red Hat, Inc. http://packetstormsecurity.com/files/172846/Facebook-Fizz-Denial-Of-Service.html [No types assigned]
  • CVE Modified by [email protected]

    Jun. 12, 2023

    Action Type Old Value New Value
    Added Reference http://packetstormsecurity.com/files/172836/polkit-Authentication-Bypass.html [No Types Assigned]
  • Reanalysis by [email protected]

    Jul. 11, 2022

    Action Type Old Value New Value
    Removed CWE NIST CWE-863
    Added CWE NIST CWE-754
  • Initial Analysis by [email protected]

    Feb. 28, 2022

    Action Type Old Value New Value
    Added CVSS V2 NIST (AV:L/AC:L/Au:N/C:C/I:C/A:C)
    Added CVSS V3.1 NIST AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
    Changed Reference Type https://bugzilla.redhat.com/show_bug.cgi?id=1961710 No Types Assigned https://bugzilla.redhat.com/show_bug.cgi?id=1961710 Issue Tracking, Patch, Vendor Advisory
    Changed Reference Type https://github.blog/2021-06-10-privilege-escalation-polkit-root-on-linux-with-bug/ No Types Assigned https://github.blog/2021-06-10-privilege-escalation-polkit-root-on-linux-with-bug/ Exploit, Third Party Advisory
    Added CWE NIST CWE-863
    Added CPE Configuration OR *cpe:2.3:a:polkit_project:polkit:*:*:*:*:*:*:*:* versions up to (excluding) 0.119
    Added CPE Configuration OR *cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:*
    Added CPE Configuration OR *cpe:2.3:o:canonical:ubuntu_linux:20.04:*:*:*:*:*:*:*
    Added CPE Configuration AND OR *cpe:2.3:a:redhat:virtualization:4.0:*:*:*:*:*:*:* *cpe:2.3:a:redhat:virtualization_host:4.0:*:*:*:*:*:*:* OR cpe:2.3:o:redhat:enterprise_linux:8.0:*:*:*:*:*:*:*
    Added CPE Configuration AND OR *cpe:2.3:a:redhat:openshift_container_platform:4.7:*:*:*:*:*:*:* OR cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:* cpe:2.3:o:redhat:enterprise_linux:8.0:*:*:*:*:*:*:*
EPSS is a daily estimate of the probability of exploitation activity being observed over the next 30 days. Following chart shows the EPSS score history of the vulnerability.
CWE - Common Weakness Enumeration

While CVE identifies specific instances of vulnerabilities, CWE categorizes the common flaws or weaknesses that can lead to vulnerabilities. CVE-2021-3560 is associated with the following CWEs:

Common Attack Pattern Enumeration and Classification (CAPEC)

Common Attack Pattern Enumeration and Classification (CAPEC) stores attack patterns, which are descriptions of the common attributes and approaches employed by adversaries to exploit the CVE-2021-3560 weaknesses.

Exploit Prediction

EPSS is a daily estimate of the probability of exploitation activity being observed over the next 30 days.

1.18 }} 0.35%

score

0.83037

percentile

CVSS31 - Vulnerability Scoring System
Attack Vector
Attack Complexity
Privileges Required
User Interaction
Scope
Confidentiality
Integrity
Availability