CVE-2025-12404
Like-it <= 2.2 - Cross-Site Request Forgery to Stored Cross-Site Scripting
Description
The Like-it plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.2. This is due to missing or incorrect nonce validation on the likeit_conf() function. This makes it possible for unauthenticated attackers to update settings and inject malicious web scripts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
INFO
Published Date :
Nov. 18, 2025, 9:15 a.m.
Last Modified :
Oct. 18, 2026, 8:10 p.m.
Remotely Exploit :
Yes !
Source :
[email protected]
CVSS Scores
| Score | Version | Severity | Vector | Exploitability Score | Impact Score | Source |
|---|---|---|---|---|---|---|
| CVSS | 134c704f-9b21-4f2e-91b3-4a467353bcc0 | |||||
| CVSS 3.1 | MEDIUM | [email protected] |
Solution
- Update the Like-it plugin to version 2.3 or later.
- Verify nonce validation is correctly implemented.
- Implement security best practices for nonce usage.
- Review plugin settings for unauthorized changes.
References to Advisories, Solutions, and Tools
Here, you will find a curated list of external links that provide in-depth
information, practical solutions, and valuable tools related to
CVE-2025-12404.
CWE - Common Weakness Enumeration
While CVE identifies
specific instances of vulnerabilities, CWE categorizes the common flaws or
weaknesses that can lead to vulnerabilities. CVE-2025-12404 is
associated with the following CWEs:
Common Attack Pattern Enumeration and Classification (CAPEC)
Common Attack Pattern Enumeration and Classification
(CAPEC)
stores attack patterns, which are descriptions of the common attributes and
approaches employed by adversaries to exploit the CVE-2025-12404
weaknesses.
We scan GitHub repositories to detect new proof-of-concept exploits. Following list is a collection of public exploits and proof-of-concepts, which have been published on GitHub (sorted by the most recently updated).
Results are limited to the first 15 repositories due to potential performance issues.
The following list is the news that have been mention
CVE-2025-12404 vulnerability anywhere in the article.
The following table lists the changes that have been made to the
CVE-2025-12404 vulnerability over time.
Vulnerability history details can be useful for understanding the evolution of a vulnerability, and for identifying the most recent changes that may impact the vulnerability's severity, exploitability, or other characteristics.
-
CVE Translated by [email protected]
Oct. 18, 2026
Action Type Old Value New Value Added Translation Title: Like-it de nikolayyordanov, Description: El plugin Like-it para WordPress es vulnerable a la Cross-Site Request Forgery en todas las versiones hasta la 2.2, inclusive. Esto se debe a la validación de nonce faltante o incorrecta en la función likeit_conf(). Esto hace posible que atacantes no autenticados actualicen la configuración e inyecten scripts web maliciosos a través de una petición falsificada, siempre que puedan engañar a un administrador del sitio para que realice una acción como hacer clic en un enlace. -
CVE Modified by [email protected]
Jun. 17, 2026
Action Type Old Value New Value Added Affected [{'vendor': 'nikolayyordanov', 'product': 'Like-it', 'versions': [{'status': 'affected', 'version': '0', 'versionType': 'semver', 'lessThanOrEqual': '2.2'}], 'defaultStatus': 'unaffected'}] -
CVE Modified by 134c704f-9b21-4f2e-91b3-4a467353bcc0
Jun. 17, 2026
Action Type Old Value New Value Added SSVC {'id': 'CVE-2025-12404', 'role': 'CISA Coordinator', 'options': [{'exploitation': 'none'}, {'automatable': 'no'}, {'technicalImpact': 'partial'}], 'version': '2.0.3', 'timestamp': '2025-11-18T14:59:14.864417Z'} -
New CVE Received by [email protected]
Nov. 18, 2025
Action Type Old Value New Value Added Description The Like-it plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.2. This is due to missing or incorrect nonce validation on the likeit_conf() function. This makes it possible for unauthenticated attackers to update settings and inject malicious web scripts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. Added CVSS V3.1 AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N Added CWE CWE-352 Added Reference https://plugins.trac.wordpress.org/browser/like-it/tags/2.2/like-it.php#L130 Added Reference https://plugins.trac.wordpress.org/browser/like-it/tags/2.2/like-it.php#L131 Added Reference https://plugins.trac.wordpress.org/browser/like-it/tags/2.2/tpl/config.php#L37 Added Reference https://www.wordfence.com/threat-intel/vulnerabilities/id/6ad1d9f5-c224-4d28-8d73-439b3c5ca24f?source=cve