CVE-2025-31390
WordPress Social Crowd plugin <= 0.9.6.1 - CSRF to Stored XSS vulnerability
Description
Cross-Site Request Forgery (CSRF) vulnerability in bdoga Social Crowd social-crowd allows Stored XSS.This issue affects Social Crowd: from n/a through <= 0.9.6.1.
INFO
Published Date :
April 9, 2025, 5:15 p.m.
Last Modified :
June 17, 2026, 9:10 a.m.
Remotely Exploit :
Yes !
Source :
[email protected]
CVSS Scores
| Score | Version | Severity | Vector | Exploitability Score | Impact Score | Source |
|---|---|---|---|---|---|---|
| CVSS | 134c704f-9b21-4f2e-91b3-4a467353bcc0 | |||||
| CVSS 3.1 | HIGH | [email protected] |
Solution
- Update Social Crowd to version 0.9.6.2 or later.
- Implement CSRF tokens for all state-changing requests.
- Sanitize user input to prevent XSS attacks.
- Validate all user-submitted data.
References to Advisories, Solutions, and Tools
Here, you will find a curated list of external links that provide in-depth
information, practical solutions, and valuable tools related to
CVE-2025-31390.
| URL | Resource |
|---|---|
| https://patchstack.com/database/Wordpress/Plugin/social-crowd/vulnerability/wordpress-social-crowd-plugin-0-9-6-1-csrf-to-stored-xss-vulnerability?_s_id=cve |
CWE - Common Weakness Enumeration
While CVE identifies
specific instances of vulnerabilities, CWE categorizes the common flaws or
weaknesses that can lead to vulnerabilities. CVE-2025-31390 is
associated with the following CWEs:
Common Attack Pattern Enumeration and Classification (CAPEC)
Common Attack Pattern Enumeration and Classification
(CAPEC)
stores attack patterns, which are descriptions of the common attributes and
approaches employed by adversaries to exploit the CVE-2025-31390
weaknesses.
We scan GitHub repositories to detect new proof-of-concept exploits. Following list is a collection of public exploits and proof-of-concepts, which have been published on GitHub (sorted by the most recently updated).
Results are limited to the first 15 repositories due to potential performance issues.
The following list is the news that have been mention
CVE-2025-31390 vulnerability anywhere in the article.
The following table lists the changes that have been made to the
CVE-2025-31390 vulnerability over time.
Vulnerability history details can be useful for understanding the evolution of a vulnerability, and for identifying the most recent changes that may impact the vulnerability's severity, exploitability, or other characteristics.
-
CVE Modified by [email protected]
Jun. 17, 2026
Action Type Old Value New Value Added Affected [{'vendor': 'bdoga', 'product': 'Social Crowd', 'versions': [{'status': 'affected', 'version': '0', 'versionType': 'custom', 'lessThanOrEqual': '0.9.6.1'}], 'packageName': 'social-crowd', 'collectionURL': 'https://wordpress.org/plugins', 'defaultStatus': 'unaffected'}] -
CVE Modified by 134c704f-9b21-4f2e-91b3-4a467353bcc0
Jun. 17, 2026
Action Type Old Value New Value Added SSVC {'id': 'CVE-2025-31390', 'role': 'CISA Coordinator', 'options': [{'exploitation': 'none'}, {'automatable': 'no'}, {'technicalImpact': 'partial'}], 'version': '2.0.3', 'timestamp': '2025-04-09T17:39:46.318019Z'} -
CVE Modified by [email protected]
Apr. 23, 2026
Action Type Old Value New Value Added CVSS V3.1 AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L -
CVE Modified by [email protected]
Apr. 01, 2026
Action Type Old Value New Value Changed Description Cross-Site Request Forgery (CSRF) vulnerability in bdoga Social Crowd allows Stored XSS. This issue affects Social Crowd: from n/a through 0.9.6.1. Cross-Site Request Forgery (CSRF) vulnerability in bdoga Social Crowd social-crowd allows Stored XSS.This issue affects Social Crowd: from n/a through <= 0.9.6.1. Removed CVSS V3.1 AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L -
New CVE Received by [email protected]
Apr. 09, 2025
Action Type Old Value New Value Added Description Cross-Site Request Forgery (CSRF) vulnerability in bdoga Social Crowd allows Stored XSS. This issue affects Social Crowd: from n/a through 0.9.6.1. Added CVSS V3.1 AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L Added CWE CWE-352 Added Reference https://patchstack.com/database/wordpress/plugin/social-crowd/vulnerability/wordpress-social-crowd-plugin-0-9-6-1-csrf-to-stored-xss-vulnerability?_s_id=cve