CVE-2025-48238
WordPress AWcode Toolkit plugin <= 1.0.18 - Cross Site Request Forgery (CSRF) to Stored XSS vulnerability
Description
Cross-Site Request Forgery (CSRF) vulnerability in awcode AWcode Toolkit awcode-toolkit allows Stored XSS.This issue affects AWcode Toolkit: from n/a through <= 1.0.18.
INFO
Published Date :
May 19, 2025, 3:15 p.m.
Last Modified :
June 17, 2026, 9:29 a.m.
Remotely Exploit :
Yes !
Source :
[email protected]
CVSS Scores
| Score | Version | Severity | Vector | Exploitability Score | Impact Score | Source |
|---|---|---|---|---|---|---|
| CVSS | 134c704f-9b21-4f2e-91b3-4a467353bcc0 | |||||
| CVSS 3.1 | HIGH | [email protected] |
Solution
- Update AWcode Toolkit to a version later than 1.0.18.
- Implement anti-CSRF tokens for all state-changing requests.
- Validate user input rigorously to prevent XSS.
References to Advisories, Solutions, and Tools
Here, you will find a curated list of external links that provide in-depth
information, practical solutions, and valuable tools related to
CVE-2025-48238.
| URL | Resource |
|---|---|
| https://patchstack.com/database/Wordpress/Plugin/awcode-toolkit/vulnerability/wordpress-awcode-toolkit-plugin-1-0-18-cross-site-request-forgery-csrf-to-stored-xss-vulnerability?_s_id=cve |
CWE - Common Weakness Enumeration
While CVE identifies
specific instances of vulnerabilities, CWE categorizes the common flaws or
weaknesses that can lead to vulnerabilities. CVE-2025-48238 is
associated with the following CWEs:
Common Attack Pattern Enumeration and Classification (CAPEC)
Common Attack Pattern Enumeration and Classification
(CAPEC)
stores attack patterns, which are descriptions of the common attributes and
approaches employed by adversaries to exploit the CVE-2025-48238
weaknesses.
We scan GitHub repositories to detect new proof-of-concept exploits. Following list is a collection of public exploits and proof-of-concepts, which have been published on GitHub (sorted by the most recently updated).
Results are limited to the first 15 repositories due to potential performance issues.
The following list is the news that have been mention
CVE-2025-48238 vulnerability anywhere in the article.
The following table lists the changes that have been made to the
CVE-2025-48238 vulnerability over time.
Vulnerability history details can be useful for understanding the evolution of a vulnerability, and for identifying the most recent changes that may impact the vulnerability's severity, exploitability, or other characteristics.
-
CVE Modified by [email protected]
Jun. 17, 2026
Action Type Old Value New Value Added Affected [{'vendor': 'awcode', 'product': 'AWcode Toolkit', 'versions': [{'status': 'affected', 'changes': [{'at': '1.0.19', 'status': 'unaffected'}], 'version': '0', 'versionType': 'custom', 'lessThanOrEqual': '1.0.18'}], 'packageName': 'awcode-toolkit', 'collectionURL': 'https://wordpress.org/plugins', 'defaultStatus': 'unaffected'}] -
CVE Modified by 134c704f-9b21-4f2e-91b3-4a467353bcc0
Jun. 17, 2026
Action Type Old Value New Value Added SSVC {'id': 'CVE-2025-48238', 'role': 'CISA Coordinator', 'options': [{'exploitation': 'none'}, {'automatable': 'no'}, {'technicalImpact': 'partial'}], 'version': '2.0.3', 'timestamp': '2025-05-19T15:11:04.959490Z'} -
CVE Modified by [email protected]
Apr. 23, 2026
Action Type Old Value New Value Added CVSS V3.1 AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L -
CVE Modified by [email protected]
Apr. 01, 2026
Action Type Old Value New Value Changed Description Cross-Site Request Forgery (CSRF) vulnerability in awcode AWcode Toolkit allows Stored XSS. This issue affects AWcode Toolkit: from n/a through 1.0.18. Cross-Site Request Forgery (CSRF) vulnerability in awcode AWcode Toolkit awcode-toolkit allows Stored XSS.This issue affects AWcode Toolkit: from n/a through <= 1.0.18. Removed CVSS V3.1 AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L -
New CVE Received by [email protected]
May. 19, 2025
Action Type Old Value New Value Added Description Cross-Site Request Forgery (CSRF) vulnerability in awcode AWcode Toolkit allows Stored XSS. This issue affects AWcode Toolkit: from n/a through 1.0.18. Added CVSS V3.1 AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L Added CWE CWE-352 Added Reference https://patchstack.com/database/wordpress/plugin/awcode-toolkit/vulnerability/wordpress-awcode-toolkit-plugin-1-0-18-cross-site-request-forgery-csrf-to-stored-xss-vulnerability?_s_id=cve