CVE-2025-49422
WordPress Support Ticket Plugin <= 1.9 - Privilege Escalation Vulnerability
Description
Incorrect Privilege Assignment vulnerability in themepassion Support Ticket support-ticket allows Privilege Escalation.This issue affects Support Ticket: from n/a through <= 1.9.
INFO
Published Date :
Aug. 20, 2025, 8:15 a.m.
Last Modified :
June 17, 2026, 9:31 a.m.
Remotely Exploit :
Yes !
Source :
[email protected]
CVSS Scores
| Score | Version | Severity | Vector | Exploitability Score | Impact Score | Source |
|---|---|---|---|---|---|---|
| CVSS | 134c704f-9b21-4f2e-91b3-4a467353bcc0 | |||||
| CVSS 3.1 | MEDIUM | [email protected] | ||||
| CVSS 3.1 | CRITICAL | [email protected] |
Solution
- Update iframe Wrapper to version 0.1.2 or later.
- Sanitize user-provided input before displaying it.
- Implement output encoding for all user-generated content.
Public PoC/Exploit Available at Github
CVE-2025-49422 has a 1 public
PoC/Exploit available at Github.
Go to the Public Exploits tab to see the list.
References to Advisories, Solutions, and Tools
Here, you will find a curated list of external links that provide in-depth
information, practical solutions, and valuable tools related to
CVE-2025-49422.
| URL | Resource |
|---|---|
| https://patchstack.com/database/Wordpress/Plugin/support-ticket/vulnerability/wordpress-support-ticket-plugin-1-9-privilege-escalation-vulnerability?_s_id=cve |
CWE - Common Weakness Enumeration
While CVE identifies
specific instances of vulnerabilities, CWE categorizes the common flaws or
weaknesses that can lead to vulnerabilities. CVE-2025-49422 is
associated with the following CWEs:
Common Attack Pattern Enumeration and Classification (CAPEC)
Common Attack Pattern Enumeration and Classification
(CAPEC)
stores attack patterns, which are descriptions of the common attributes and
approaches employed by adversaries to exploit the CVE-2025-49422
weaknesses.
We scan GitHub repositories to detect new proof-of-concept exploits. Following list is a collection of public exploits and proof-of-concepts, which have been published on GitHub (sorted by the most recently updated).
None
Results are limited to the first 15 repositories due to potential performance issues.
The following list is the news that have been mention
CVE-2025-49422 vulnerability anywhere in the article.
The following table lists the changes that have been made to the
CVE-2025-49422 vulnerability over time.
Vulnerability history details can be useful for understanding the evolution of a vulnerability, and for identifying the most recent changes that may impact the vulnerability's severity, exploitability, or other characteristics.
-
CVE Modified by [email protected]
Jun. 17, 2026
Action Type Old Value New Value Added Affected [{'vendor': 'themepassion', 'product': 'Support Ticket', 'versions': [{'status': 'affected', 'version': '0', 'versionType': 'custom', 'lessThanOrEqual': '1.9'}], 'packageName': 'support-ticket', 'collectionURL': 'https://wordpress.org/plugins', 'defaultStatus': 'unaffected'}] -
CVE Modified by 134c704f-9b21-4f2e-91b3-4a467353bcc0
Jun. 17, 2026
Action Type Old Value New Value Added SSVC {'id': 'CVE-2025-49422', 'role': 'CISA Coordinator', 'options': [{'exploitation': 'none'}, {'automatable': 'no'}, {'technicalImpact': 'partial'}], 'version': '2.0.3', 'timestamp': '2025-08-20T13:56:24.840541Z'} -
CVE Modified by [email protected]
Apr. 23, 2026
Action Type Old Value New Value Added CVSS V3.1 AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H -
CVE Modified by [email protected]
Apr. 01, 2026
Action Type Old Value New Value Changed Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Aelora iframe Wrapper allows DOM-Based XSS. This issue affects iframe Wrapper: from n/a through 0.1.1. Incorrect Privilege Assignment vulnerability in themepassion Support Ticket support-ticket allows Privilege Escalation.This issue affects Support Ticket: from n/a through <= 1.9. Removed CVSS V3.1 AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L Added CWE CWE-266 Removed CWE CWE-79 Added Reference https://patchstack.com/database/Wordpress/Plugin/support-ticket/vulnerability/wordpress-support-ticket-plugin-1-9-privilege-escalation-vulnerability?_s_id=cve Removed Reference https://patchstack.com/database/wordpress/plugin/iframe-wrapper/vulnerability/wordpress-iframe-wrapper-plugin-0-1-1-cross-site-scripting-xss-vulnerability?_s_id=cve -
New CVE Received by [email protected]
Aug. 20, 2025
Action Type Old Value New Value Added Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Aelora iframe Wrapper allows DOM-Based XSS. This issue affects iframe Wrapper: from n/a through 0.1.1. Added CVSS V3.1 AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L Added CWE CWE-79 Added Reference https://patchstack.com/database/wordpress/plugin/iframe-wrapper/vulnerability/wordpress-iframe-wrapper-plugin-0-1-1-cross-site-scripting-xss-vulnerability?_s_id=cve