CVE-2025-58966
WordPress NEX-Forms LITE plugin < 8.2 - Cross Site Scripting (XSS) vulnerability
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Basix NEX-Forms LITE nex-forms-lite allows Reflected XSS.This issue affects NEX-Forms LITE: from n/a through < 8.2.
INFO
Published Date :
Oct. 22, 2025, 3:15 p.m.
Last Modified :
Oct. 23, 2026, 10:10 p.m.
Remotely Exploit :
Yes !
Source :
[email protected]
CVSS Scores
| Score | Version | Severity | Vector | Exploitability Score | Impact Score | Source |
|---|---|---|---|---|---|---|
| CVSS | 134c704f-9b21-4f2e-91b3-4a467353bcc0 | |||||
| CVSS 3.1 | HIGH | 134c704f-9b21-4f2e-91b3-4a467353bcc0 | ||||
| CVSS 3.1 | HIGH | [email protected] |
Solution
- Upgrade NEX-Forms LITE to version 8.2 or newer.
- Apply vendor-supplied patches for the affected component.
- Validate input to prevent script execution.
- Sanitize all user-supplied data properly.
Public PoC/Exploit Available at Github
CVE-2025-58966 has a 1 public
PoC/Exploit available at Github.
Go to the Public Exploits tab to see the list.
References to Advisories, Solutions, and Tools
Here, you will find a curated list of external links that provide in-depth
information, practical solutions, and valuable tools related to
CVE-2025-58966.
| URL | Resource |
|---|---|
| https://patchstack.com/database/Wordpress/Plugin/nex-forms-lite/vulnerability/wordpress-nex-forms-lite-plugin-8-2-cross-site-scripting-xss-vulnerability?_s_id=cve |
CWE - Common Weakness Enumeration
While CVE identifies
specific instances of vulnerabilities, CWE categorizes the common flaws or
weaknesses that can lead to vulnerabilities. CVE-2025-58966 is
associated with the following CWEs:
Common Attack Pattern Enumeration and Classification (CAPEC)
Common Attack Pattern Enumeration and Classification
(CAPEC)
stores attack patterns, which are descriptions of the common attributes and
approaches employed by adversaries to exploit the CVE-2025-58966
weaknesses.
We scan GitHub repositories to detect new proof-of-concept exploits. Following list is a collection of public exploits and proof-of-concepts, which have been published on GitHub (sorted by the most recently updated).
None
Results are limited to the first 15 repositories due to potential performance issues.
The following list is the news that have been mention
CVE-2025-58966 vulnerability anywhere in the article.
The following table lists the changes that have been made to the
CVE-2025-58966 vulnerability over time.
Vulnerability history details can be useful for understanding the evolution of a vulnerability, and for identifying the most recent changes that may impact the vulnerability's severity, exploitability, or other characteristics.
-
CVE Translated by [email protected]
Oct. 23, 2026
Action Type Old Value New Value Changed Translation Title: NEX-Forms LITE de Basix, Description: Neutralización Incorrecta de Entrada Durante la Generación de Páginas Web ('cross-site scripting') vulnerabilidad en Basix NEX-Forms LITE nex-forms-lite permite XSS Reflejado. Este problema afecta a NEX-Forms LITE: desde n/d hasta < 8.2. Title: NEX-Forms LITE de Basix, Description: Neutralización Incorrecta de Entrada Durante la Generación de Páginas Web ('cross-site scripting') vulnerabilidad en Basix NEX-Forms LITE nex-forms-lite permite XSS Reflejado. Este problema afecta a NEX-Forms LITE: desde n/d hasta anterior a 8.2. -
CVE Translated by [email protected]
Oct. 08, 2026
Action Type Old Value New Value Added Translation Title: NEX-Forms LITE de Basix, Description: Neutralización Incorrecta de Entrada Durante la Generación de Páginas Web ('cross-site scripting') vulnerabilidad en Basix NEX-Forms LITE nex-forms-lite permite XSS Reflejado. Este problema afecta a NEX-Forms LITE: desde n/d hasta < 8.2. -
CVE Modified by [email protected]
Jun. 17, 2026
Action Type Old Value New Value Added Affected [{'vendor': 'Basix', 'product': 'NEX-Forms LITE', 'versions': [{'status': 'affected', 'changes': [{'at': '8.2', 'status': 'unaffected'}], 'version': '0', 'versionType': 'custom', 'lessThanOrEqual': '8.2'}], 'packageName': 'nex-forms-lite', 'collectionURL': 'https://wordpress.org/plugins', 'defaultStatus': 'unaffected'}] -
CVE Modified by 134c704f-9b21-4f2e-91b3-4a467353bcc0
Jun. 17, 2026
Action Type Old Value New Value Added SSVC {'id': 'CVE-2025-58966', 'role': 'CISA Coordinator', 'options': [{'exploitation': 'none'}, {'automatable': 'no'}, {'technicalImpact': 'partial'}], 'version': '2.0.3', 'timestamp': '2025-10-23T13:44:50.311896Z'} -
CVE Modified by 134c704f-9b21-4f2e-91b3-4a467353bcc0
Apr. 27, 2026
Action Type Old Value New Value Removed CVSS V3.1 AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N -
CVE Modified by [email protected]
Apr. 23, 2026
Action Type Old Value New Value Added CVSS V3.1 AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L -
CVE Modified by [email protected]
Jan. 20, 2026
Action Type Old Value New Value Added Reference https://patchstack.com/database/Wordpress/Plugin/nex-forms-lite/vulnerability/wordpress-nex-forms-lite-plugin-8-2-cross-site-scripting-xss-vulnerability?_s_id=cve Removed Reference https://vdp.patchstack.com/database/Wordpress/Plugin/nex-forms-lite/vulnerability/wordpress-nex-forms-lite-plugin-8-2-cross-site-scripting-xss-vulnerability?_s_id=cve -
CVE Modified by [email protected]
Nov. 13, 2025
Action Type Old Value New Value Added Reference https://vdp.patchstack.com/database/Wordpress/Plugin/nex-forms-lite/vulnerability/wordpress-nex-forms-lite-plugin-8-2-cross-site-scripting-xss-vulnerability?_s_id=cve Removed Reference https://vdp.patchstack.com/database/Wordpress/Plugin/nex-forms-lite/vulnerability/wordpress-nex-forms-lite-plugin-8-2-cross-site-scripting-xss-vulnerability -
CVE Modified by 134c704f-9b21-4f2e-91b3-4a467353bcc0
Oct. 23, 2025
Action Type Old Value New Value Added CVSS V3.1 AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N -
New CVE Received by [email protected]
Oct. 22, 2025
Action Type Old Value New Value Added Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Basix NEX-Forms LITE nex-forms-lite allows Reflected XSS.This issue affects NEX-Forms LITE: from n/a through < 8.2. Added CWE CWE-79 Added Reference https://vdp.patchstack.com/database/Wordpress/Plugin/nex-forms-lite/vulnerability/wordpress-nex-forms-lite-plugin-8-2-cross-site-scripting-xss-vulnerability