3.4
LOW CVSS 3.1
CVE-2026-115917
vLLM: Permissive default CORS origins allow cross-origin requests to the vLLM HTTP server
Description

vLLM is an inference and serving engine for large language models. Prior to 0.32.0, the OpenAI-compatible server configures Starlette CORSMiddleware with allowed_origins set to a wildcard by default. A malicious web page can use a victim's browser to reach an unauthenticated vLLM server on localhost, an internal network, or a VPN, call endpoints including GET /v1/models and POST /v1/chat/completions, consume GPU resources, and read responses. Cookie-based cross-site request forgery does not apply because credentials are disabled by default, and deployments requiring bearer authentication are exposed only when the caller already has a usable token. This issue is fixed in version 0.32.0.

INFO

Published Date :

Oct. 26, 2026, 6:17 p.m.

Last Modified :

Oct. 26, 2026, 6:34 p.m.

Remotely Exploit :

Yes !
Affected Products

The following products are affected by CVE-2026-115917 vulnerability. Even if cvefeed.io is aware of the exact versions of the products that are affected, the information is not represented in the table below.

ID Vendor Product Action
1 Vllm-project vllm
1 Vllm vllm
CVSS Scores
The Common Vulnerability Scoring System is a standardized framework for assessing the severity of vulnerabilities in software and systems. We collect and displays CVSS scores from various sources for each CVE.
Score Version Severity Vector Exploitability Score Impact Score Source
CVSS 3.1 LOW MITRE-CVE
CVSS 3.1 LOW [email protected]
Solution
Update vLLM to version 0.32.0 or later to fix default CORS wildcard configuration.
  • Update vLLM to version 0.32.0 or later.
  • Review and restrict allowed_origins in Starlette CORSMiddleware.
  • Ensure sensitive endpoints require proper authentication.
  • Disable wildcard '*' for allowed_origins.
References to Advisories, Solutions, and Tools
CWE - Common Weakness Enumeration

While CVE identifies specific instances of vulnerabilities, CWE categorizes the common flaws or weaknesses that can lead to vulnerabilities. CVE-2026-115917 is associated with the following CWEs:

Common Attack Pattern Enumeration and Classification (CAPEC)

Common Attack Pattern Enumeration and Classification (CAPEC) stores attack patterns, which are descriptions of the common attributes and approaches employed by adversaries to exploit the CVE-2026-115917 weaknesses.

We scan GitHub repositories to detect new proof-of-concept exploits. Following list is a collection of public exploits and proof-of-concepts, which have been published on GitHub (sorted by the most recently updated).

Results are limited to the first 15 repositories due to potential performance issues.

The following list is the news that have been mention CVE-2026-115917 vulnerability anywhere in the article.

The following table lists the changes that have been made to the CVE-2026-115917 vulnerability over time.

Vulnerability history details can be useful for understanding the evolution of a vulnerability, and for identifying the most recent changes that may impact the vulnerability's severity, exploitability, or other characteristics.

  • New CVE Received by [email protected]

    Oct. 26, 2026

    Action Type Old Value New Value
    Added Description vLLM is an inference and serving engine for large language models. Prior to 0.32.0, the OpenAI-compatible server configures Starlette CORSMiddleware with allowed_origins set to a wildcard by default. A malicious web page can use a victim's browser to reach an unauthenticated vLLM server on localhost, an internal network, or a VPN, call endpoints including GET /v1/models and POST /v1/chat/completions, consume GPU resources, and read responses. Cookie-based cross-site request forgery does not apply because credentials are disabled by default, and deployments requiring bearer authentication are exposed only when the caller already has a usable token. This issue is fixed in version 0.32.0.
    Added CVSS V3.1 AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:N/A:N
    Added CWE CWE-942
    Added Affected New affected value received. <a href="https://github.com/CVEProject/cvelistV5/blob/main/cves/2026/115xxx/CVE-2026-115917.json">CVE-2026-115917</a>
    Added Reference https://github.com/vllm-project/vllm/commit/fcae5c98870ff2c20659731dce7ba3a3ff0d48aa
    Added Reference https://github.com/vllm-project/vllm/pull/61009
    Added Reference https://github.com/vllm-project/vllm/releases/tag/v0.32.0
    Added Reference https://github.com/vllm-project/vllm/security/advisories/GHSA-vvpg-rrww-wpmh
EPSS is a daily estimate of the probability of exploitation activity being observed over the next 30 days. Following chart shows the EPSS score history of the vulnerability.