6.4
MEDIUM CVSS 3.1
CVE-2026-122059
WP ImageViewer <= 3.0.2 - Authenticated (Subscriber+) Stored DOM-Based Cross-Site Scripting via Image 'alt' Attribute
Description

The WP ImageViewer plugin for WordPress is vulnerable to Stored DOM-Based Cross-Site Scripting via the 'img.alt' parameter in all versions up to, and including, 3.0.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires a front-end content plugin such as bbPress to be active, as it grants Subscriber-level users the bbp_participant capability needed to publish image-bearing content containing the encoded payload. Exploitation by attackers with contributor-level access and above requires that the site allows Contributors (or higher) to submit image HTML in post content — the WordPress default. On a default installation, where that is not configured, the vulnerability requires attackers with custom-level access and above.

INFO

Published Date :

Nov. 7, 2026, 12:17 p.m.

Last Modified :

Nov. 7, 2026, 12:17 p.m.

Remotely Exploit :

Yes !
Affected Products

The following products are affected by CVE-2026-122059 vulnerability. Even if cvefeed.io is aware of the exact versions of the products that are affected, the information is not represented in the table below.

ID Vendor Product Action
1 Mpol wp_imageviewer
CVSS Scores
The Common Vulnerability Scoring System is a standardized framework for assessing the severity of vulnerabilities in software and systems. We collect and displays CVSS scores from various sources for each CVE.
Score Version Severity Vector Exploitability Score Impact Score Source
CVSS 3.1 MEDIUM MITRE-CVE
CVSS 3.1 MEDIUM [email protected]
Solution
Update the WP ImageViewer plugin to the latest version to fix stored DOM-based XSS.
  • Update WP ImageViewer plugin to version 3.0.3 or later.
  • Sanitize and escape all user inputs.
  • Restrict user roles with image upload capabilities.
  • Review plugin security configurations.
CWE - Common Weakness Enumeration

While CVE identifies specific instances of vulnerabilities, CWE categorizes the common flaws or weaknesses that can lead to vulnerabilities. CVE-2026-122059 is associated with the following CWEs:

Common Attack Pattern Enumeration and Classification (CAPEC)

Common Attack Pattern Enumeration and Classification (CAPEC) stores attack patterns, which are descriptions of the common attributes and approaches employed by adversaries to exploit the CVE-2026-122059 weaknesses.

We scan GitHub repositories to detect new proof-of-concept exploits. Following list is a collection of public exploits and proof-of-concepts, which have been published on GitHub (sorted by the most recently updated).

Results are limited to the first 15 repositories due to potential performance issues.

The following list is the news that have been mention CVE-2026-122059 vulnerability anywhere in the article.

The following table lists the changes that have been made to the CVE-2026-122059 vulnerability over time.

Vulnerability history details can be useful for understanding the evolution of a vulnerability, and for identifying the most recent changes that may impact the vulnerability's severity, exploitability, or other characteristics.

  • New CVE Received by [email protected]

    Nov. 07, 2026

    Action Type Old Value New Value
    Added Description The WP ImageViewer plugin for WordPress is vulnerable to Stored DOM-Based Cross-Site Scripting via the 'img.alt' parameter in all versions up to, and including, 3.0.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires a front-end content plugin such as bbPress to be active, as it grants Subscriber-level users the bbp_participant capability needed to publish image-bearing content containing the encoded payload. Exploitation by attackers with contributor-level access and above requires that the site allows Contributors (or higher) to submit image HTML in post content — the WordPress default. On a default installation, where that is not configured, the vulnerability requires attackers with custom-level access and above.
    Added CVSS V3.1 AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
    Added CWE CWE-79
    Added Affected New affected value received. <a href="https://github.com/CVEProject/cvelistV5/blob/main/cves/2026/122xxx/CVE-2026-122059.json">CVE-2026-122059</a>
    Added Reference https://codeberg.org/cyclotouriste/wp-imageviewer/commit/44601a13af7f7874c62c98956c6747322a6ab3c0
    Added Reference https://plugins.trac.wordpress.org/browser/wp-imageviewer/tags/3.0.2/wp-imageviewer-init.js#L132
    Added Reference https://plugins.trac.wordpress.org/browser/wp-imageviewer/tags/3.0.2/wp-imageviewer-init.js#L139
    Added Reference https://plugins.trac.wordpress.org/browser/wp-imageviewer/tags/3.0.2/wp-imageviewer-init.js#L224
    Added Reference https://plugins.trac.wordpress.org/browser/wp-imageviewer/tags/3.0.3/wp-imageviewer-init.js
    Added Reference https://www.wordfence.com/threat-intel/vulnerabilities/id/2d3f78b4-04c7-4978-919f-997b39307c5b?source=cve
EPSS is a daily estimate of the probability of exploitation activity being observed over the next 30 days. Following chart shows the EPSS score history of the vulnerability.