CVE-2026-22339
WordPress WPJobster theme <= 6.3.5 - Reflected Cross Site Scripting (XSS) vulnerability
Description
Unauthenticated Cross Site Scripting (XSS) in WPJobster <= 6.3.5 versions.
INFO
Published Date :
June 17, 2026, 1:20 p.m.
Last Modified :
Oct. 26, 2026, 11:10 a.m.
Remotely Exploit :
Yes !
Source :
[email protected]
CVSS Scores
| Score | Version | Severity | Vector | Exploitability Score | Impact Score | Source |
|---|---|---|---|---|---|---|
| CVSS | 134c704f-9b21-4f2e-91b3-4a467353bcc0 | |||||
| CVSS 3.1 | HIGH | 21595511-bba5-4825-b968-b78d1f9984a3 | ||||
| CVSS 3.1 | HIGH | MITRE-CVE | ||||
| CVSS 3.1 | HIGH | [email protected] |
Solution
- Update WPJobster plugin to version 6.3.6 or later.
- Verify plugin updates are applied.
References to Advisories, Solutions, and Tools
Here, you will find a curated list of external links that provide in-depth
information, practical solutions, and valuable tools related to
CVE-2026-22339.
| URL | Resource |
|---|---|
| https://patchstack.com/database/wordpress/theme/wpjobster/vulnerability/wordpress-wpjobster-theme-6-3-5-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve |
CWE - Common Weakness Enumeration
While CVE identifies
specific instances of vulnerabilities, CWE categorizes the common flaws or
weaknesses that can lead to vulnerabilities. CVE-2026-22339 is
associated with the following CWEs:
Common Attack Pattern Enumeration and Classification (CAPEC)
Common Attack Pattern Enumeration and Classification
(CAPEC)
stores attack patterns, which are descriptions of the common attributes and
approaches employed by adversaries to exploit the CVE-2026-22339
weaknesses.
We scan GitHub repositories to detect new proof-of-concept exploits. Following list is a collection of public exploits and proof-of-concepts, which have been published on GitHub (sorted by the most recently updated).
Results are limited to the first 15 repositories due to potential performance issues.
The following list is the news that have been mention
CVE-2026-22339 vulnerability anywhere in the article.
The following table lists the changes that have been made to the
CVE-2026-22339 vulnerability over time.
Vulnerability history details can be useful for understanding the evolution of a vulnerability, and for identifying the most recent changes that may impact the vulnerability's severity, exploitability, or other characteristics.
-
CVE Translated by [email protected]
Oct. 26, 2026
Action Type Old Value New Value Added Translation Title: WPJobster de Jobster Marketplace, Description: Scripting entre sitios (XSS) no autenticado en versiones de WPJobster menor o igual que 6.3.5. -
CVE Modified by 134c704f-9b21-4f2e-91b3-4a467353bcc0
Jun. 17, 2026
Action Type Old Value New Value Added SSVC {'id': 'CVE-2026-22339', 'role': 'CISA Coordinator', 'options': [{'exploitation': 'none'}, {'automatable': 'no'}, {'technicalImpact': 'partial'}], 'version': '2.0.3', 'timestamp': '2026-06-17T15:21:31.350557Z'} -
New CVE Received by [email protected]
Jun. 17, 2026
Action Type Old Value New Value Added Affected [{'vendor': 'Jobster Marketplace', 'product': 'WPJobster', 'versions': [{'status': 'affected', 'version': 'n/a', 'versionType': 'custom', 'lessThanOrEqual': '6.3.5'}], 'packageName': 'wpjobster', 'collectionURL': 'https://wordpress.org/themes', 'defaultStatus': 'unaffected'}] Added Description Unauthenticated Cross Site Scripting (XSS) in WPJobster <= 6.3.5 versions. Added CVSS V3.1 AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L Added CWE CWE-79 Added Reference https://patchstack.com/database/wordpress/theme/wpjobster/vulnerability/wordpress-wpjobster-theme-6-3-5-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve