5.3
MEDIUM CVSS 3.1
CVE-2026-2839
Advanced Custom Fields: Extended <= 0.9.2.7 - Missing Authorization to Unauthenticated Data Exposure via Multiple AJAX Endpoints
Description

The Advanced Custom Fields: Extended plugin for WordPress is vulnerable to unauthorized access of data and triggering of server-side actions in all versions up to, and including, 0.9.2.7. This is due to multiple AJAX handlers registered for unauthenticated users (`wp_ajax_nopriv_*`) that fail to implement proper `current_user_can()` authorization checks. While these handlers use ACF's `acf_verify_ajax()` function to validate cryptographic nonces, the `acf_nonce` values are generated for guest users and publicly exposed in the page source of any frontend page utilizing an ACF form. This makes it possible for unauthenticated attackers to extract the guest nonce and bypass WordPress visibility permissions, leading to the unauthorized disclosure of post titles and internal Flexible Content layout structures. The vulnerability was partially patched in version 0.9.2.4.

INFO

Published Date :

Oct. 28, 2026, 7:16 a.m.

Last Modified :

Oct. 28, 2026, 7:16 a.m.

Remotely Exploit :

Yes !
Affected Products

The following products are affected by CVE-2026-2839 vulnerability. Even if cvefeed.io is aware of the exact versions of the products that are affected, the information is not represented in the table below.

ID Vendor Product Action
1 Acfextended advanced_custom_fields_extended
CVSS Scores
The Common Vulnerability Scoring System is a standardized framework for assessing the severity of vulnerabilities in software and systems. We collect and displays CVSS scores from various sources for each CVE.
Score Version Severity Vector Exploitability Score Impact Score Source
CVSS 3.1 MEDIUM MITRE-CVE
CVSS 3.1 MEDIUM [email protected]
Solution
Update the Advanced Custom Fields: Extended plugin to the latest version to fix authorization flaws.
  • Update the Advanced Custom Fields: Extended plugin.
  • Verify AJAX handlers implement proper authorization checks.
  • Remove unauthenticated AJAX handlers if not needed.
CWE - Common Weakness Enumeration

While CVE identifies specific instances of vulnerabilities, CWE categorizes the common flaws or weaknesses that can lead to vulnerabilities. CVE-2026-2839 is associated with the following CWEs:

Common Attack Pattern Enumeration and Classification (CAPEC)

Common Attack Pattern Enumeration and Classification (CAPEC) stores attack patterns, which are descriptions of the common attributes and approaches employed by adversaries to exploit the CVE-2026-2839 weaknesses.

We scan GitHub repositories to detect new proof-of-concept exploits. Following list is a collection of public exploits and proof-of-concepts, which have been published on GitHub (sorted by the most recently updated).

Results are limited to the first 15 repositories due to potential performance issues.

The following list is the news that have been mention CVE-2026-2839 vulnerability anywhere in the article.

The following table lists the changes that have been made to the CVE-2026-2839 vulnerability over time.

Vulnerability history details can be useful for understanding the evolution of a vulnerability, and for identifying the most recent changes that may impact the vulnerability's severity, exploitability, or other characteristics.

  • New CVE Received by [email protected]

    Oct. 28, 2026

    Action Type Old Value New Value
    Added Description The Advanced Custom Fields: Extended plugin for WordPress is vulnerable to unauthorized access of data and triggering of server-side actions in all versions up to, and including, 0.9.2.7. This is due to multiple AJAX handlers registered for unauthenticated users (`wp_ajax_nopriv_*`) that fail to implement proper `current_user_can()` authorization checks. While these handlers use ACF's `acf_verify_ajax()` function to validate cryptographic nonces, the `acf_nonce` values are generated for guest users and publicly exposed in the page source of any frontend page utilizing an ACF form. This makes it possible for unauthenticated attackers to extract the guest nonce and bypass WordPress visibility permissions, leading to the unauthorized disclosure of post titles and internal Flexible Content layout structures. The vulnerability was partially patched in version 0.9.2.4.
    Added CVSS V3.1 AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
    Added CWE CWE-862
    Added Affected New affected value received. <a href="https://github.com/CVEProject/cvelistV5/blob/main/cves/2026/2xxx/CVE-2026-2839.json">CVE-2026-2839</a>
    Added Reference https://plugins.trac.wordpress.org/browser/acf-extended/trunk/includes/fields/field-advanced-link.php#L25
    Added Reference https://plugins.trac.wordpress.org/browser/acf-extended/trunk/includes/fields/field-advanced-link.php#L603
    Added Reference https://plugins.trac.wordpress.org/browser/acf-extended/trunk/includes/fields/field-flexible-content-async.php#L151
    Added Reference https://plugins.trac.wordpress.org/browser/acf-extended/trunk/includes/fields/field-flexible-content-async.php#L24
    Added Reference https://plugins.trac.wordpress.org/changeset/3516027/
    Added Reference https://plugins.trac.wordpress.org/changeset/3754818/
    Added Reference https://www.wordfence.com/threat-intel/vulnerabilities/id/9954ef37-bae0-48fb-9654-ff54750c46c2?source=cve
EPSS is a daily estimate of the probability of exploitation activity being observed over the next 30 days. Following chart shows the EPSS score history of the vulnerability.