0.0
NA
CVE-2026-92887
Apache OFBiz: REST API authentication bypassed by default when the auth attribute is omitted from a .rest.xml operation
Description

Incorrect default value in the REST API framework's .rest.xml definition parser (ModelApiReader) in Apache OFBiz through 24.09.07 on all platforms allows a remote, unauthenticated attacker to invoke a REST API operation without providing valid credentials via a .rest.xml resource or operation definition that omits the auth attribute, which ModelApiReader incorrectly resolves to false instead of the true default declared by rest-api.xsd. Users are recommended to upgrade to version 24.09.08, which fixes this issue.

INFO

Published Date :

Nov. 5, 2026, 2:17 p.m.

Last Modified :

Nov. 5, 2026, 2:48 p.m.

Remotely Exploit :

No
Affected Products

The following products are affected by CVE-2026-92887 vulnerability. Even if cvefeed.io is aware of the exact versions of the products that are affected, the information is not represented in the table below.

ID Vendor Product Action
1 Apache ofbiz
Solution
Upgrade Apache OFBiz to version 24.09.08 to address the authentication bypass vulnerability.
  • Upgrade Apache OFBiz to version 24.09.08.
  • Ensure authentication is properly configured for all API operations.
References to Advisories, Solutions, and Tools

Here, you will find a curated list of external links that provide in-depth information, practical solutions, and valuable tools related to CVE-2026-92887.

URL Resource
https://lists.apache.org/thread.html/7b2syzksp7klt9fvhdg0olldvs2g83lz
CWE - Common Weakness Enumeration

While CVE identifies specific instances of vulnerabilities, CWE categorizes the common flaws or weaknesses that can lead to vulnerabilities. CVE-2026-92887 is associated with the following CWEs:

We scan GitHub repositories to detect new proof-of-concept exploits. Following list is a collection of public exploits and proof-of-concepts, which have been published on GitHub (sorted by the most recently updated).

Results are limited to the first 15 repositories due to potential performance issues.

The following list is the news that have been mention CVE-2026-92887 vulnerability anywhere in the article.

The following table lists the changes that have been made to the CVE-2026-92887 vulnerability over time.

Vulnerability history details can be useful for understanding the evolution of a vulnerability, and for identifying the most recent changes that may impact the vulnerability's severity, exploitability, or other characteristics.

  • New CVE Received by [email protected]

    Nov. 05, 2026

    Action Type Old Value New Value
    Added Description Incorrect default value in the REST API framework's .rest.xml definition parser (ModelApiReader) in Apache OFBiz through 24.09.07 on all platforms allows a remote, unauthenticated attacker to invoke a REST API operation without providing valid credentials via a .rest.xml resource or operation definition that omits the auth attribute, which ModelApiReader incorrectly resolves to false instead of the true default declared by rest-api.xsd. Users are recommended to upgrade to version 24.09.08, which fixes this issue.
    Added CWE CWE-306
    Added CWE CWE-1188
    Added Affected New affected value received. <a href="https://github.com/CVEProject/cvelistV5/blob/main/cves/2026/92xxx/CVE-2026-92887.json">CVE-2026-92887</a>
    Added Reference https://lists.apache.org/thread.html/7b2syzksp7klt9fvhdg0olldvs2g83lz
EPSS is a daily estimate of the probability of exploitation activity being observed over the next 30 days. Following chart shows the EPSS score history of the vulnerability.